const regex = /ng-show="([\s\S]*)"/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('ng-show="([\\s\\S]*)"', '')
const str = `<span ng-show="vm.formName.fieldName.\$error.required">*</span>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);