use strict;
my $str = '<span ng-show="vm.formName.fieldName.$error.required">*</span>';
my $regex = qr/ng-show="([\s\S]*)"/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";