// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<span id="ctl00_MainContent_ListView2_ctrl2_ctl01_[^"]+" class="vehicledetailTable" style="display:inline-block;width:475px;">OWNED</span><br />"#).unwrap();
let string = "<span id=\"ctl00_MainContent_ListView2_ctrl2_ctl01_Label17\" class=\"vehicledetailTable\" style=\"display:inline-block;width:475px;\">OWNED</span><br />
<span id=\"ctl00_MainContent_ListView2_ctrl2_ctl01_Label18\" class=\"vehicledetailTable\" style=\"display:inline-block;width:475px;\">OWNED</span><br />
<span id=\"ctl00_MainContent_ListView2_ctrl2_ctl01_Label19\" class=\"vehicledetailTable\" style=\"display:inline-block;width:475px;\">OWNED</span><br />";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}