import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*n.?t?.*reply.*@(.+\\.)+.+";
final String string = "dontreply@a.b.com\n"
+ "noreply@a.b3.com\n"
+ "donotreply@a.b\n"
+ "no-reply@a.b\n"
+ "pleasedonotreply@a.b\n"
+ "do-not-replyplease@a.b\n"
+ "dontreplyplease@a.b";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}