const regex = /.*n.?t?.*reply.*@(.+\.)+.+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*n.?t?.*reply.*@(.+\\.)+.+', 'g')
const str = `dontreply@a.b.com
noreply@a.b3.com
donotreply@a.b
no-reply@a.b
pleasedonotreply@a.b
do-not-replyplease@a.b
dontreplyplease@a.b`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}