$re = '/.*n.?t?.*reply.*@(.+\.)+.+/';
$str = 'dontreply@a.b.com
noreply@a.b3.com
donotreply@a.b
no-reply@a.b
pleasedonotreply@a.b
do-not-replyplease@a.b
dontreplyplease@a.b';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);