import re
regex = re.compile(r".*n.?t?.*reply.*@(.+\.)+.+")
test_str = ("dontreply@a.b.com\n"
"noreply@a.b3.com\n"
"donotreply@a.b\n"
"no-reply@a.b\n"
"pleasedonotreply@a.b\n"
"do-not-replyplease@a.b\n"
"dontreplyplease@a.b")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")