// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*n.?t?.*reply.*@(.+\.)+.+").unwrap();
let string = "dontreply@a.b.com
noreply@a.b3.com
donotreply@a.b
no-reply@a.b
pleasedonotreply@a.b
do-not-replyplease@a.b
dontreplyplease@a.b";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}