const regex = /\b(?!100)\d{6,9}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?!100)\\d{6,9}', 'g')
const str = `123456789012
Don't match: 10012345
Match: 1045677
Don't match:
1004567
Don't match: num="10034567" test
Match just the middle number in the line: num="10048876" 1200476, 1008888`;
const subst = `*`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);