const regex = /summary:.*?in\s*(?:(?<hours>[\d\.]+) h)?\s*(?:(?<minutes>[\d\.]+) min)?\s*(?:(?<seconds>[\d\.]+) sec)?.*?average of\s*(?<speed>[\d\.]+ [a-zA-Z]+\/s)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('summary:.*?in\\s*(?:(?<hours>[\\d\\.]+) h)?\\s*(?:(?<minutes>[\\d\\.]+) min)?\\s*(?:(?<seconds>[\\d\\.]+) sec)?.*?average of\\s*(?<speed>[\\d\\.]+ [a-zA-Z]+\\\/s)', 'g')
const str = `summary: 0.0 KiByte in 0.3 sec - average of 0.0 B/s
summary: 0.0 KiByte in 12 h 24 min - average of 12.0 KiB/s
summary: 0.0 KiByte in 12 min - average of 12.0 MiB/s`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}