import Foundation
let pattern = #"{{\*(\w+)}}((?:.|\n)+?){{\/\w+}}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
<table>
<tbody>
<tr>
<th>Trainee</th>
<th>Status</th>
<th>Invited</th>
<th>Score</th>
<th>Action</th>
</tr>
{{*Trainees}}
<tr>
<td>{{display_name}}</td>
<td>{{status}}</td>
<td>{{invited_date}}</td>
<td>{{percentage}}</td>
<td>Some action button</td>
</tr>
{{/Trainees}}
</tbody>
</table>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}