using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=.).(?=[^@]*?.@)|(?:(?<=@.)|(?!^)\G(?=[^@]*$)).(?=.*\.)";
string substitution = @"*";
string input = @"test01@gmail.com";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}