// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(Channel\:) (.+?) \(Total memory: ()\)$").unwrap();
let string = "Mo 04:30PM - 05:50PM
Fr 12:00PM - 01:20PM
fooo
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}