#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)-+(?:[0-9]*)-+\n(.*)\n((?:ERROR.*\n)*)real\s*(.*)\n.*\n.*\n\s*(.*)\s\s.*\n?"
Local $sString = "-----------1------------" & @CRLF & _
"path/to/file1" & @CRLF & _
"real 0.21" & @CRLF & _
"user 0.01" & @CRLF & _
"sys 0.02" & @CRLF & _
" 11378688 maximum resident set size" & @CRLF & _
"-----------2------------" & @CRLF & _
"path/to/file2" & @CRLF & _
"real 0.21" & @CRLF & _
"user 0.01" & @CRLF & _
"sys 0.02" & @CRLF & _
" 11378688 maximum resident set size" & @CRLF & _
"-----------3------------" & @CRLF & _
"path/to/file3" & @CRLF & _
"real 0.21" & @CRLF & _
"user 0.01" & @CRLF & _
"sys 0.02" & @CRLF & _
" 11378688 maximum resident set size" & @CRLF & _
"-----------4------------" & @CRLF & _
"path/to/file4" & @CRLF & _
"ERROR: Lorem ipsum error" & @CRLF & _
"ERROR2: Lorem ipsum error 2" & @CRLF & _
"real 0.59" & @CRLF & _
"user 0.01" & @CRLF & _
"sys 0.02" & @CRLF & _
" 11378688 maximum resident set size"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")