# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"-+(?:[0-9]*)-+\n(.*)\n((?:ERROR.*\n)*)real\s*(.*)\n.*\n.*\n\s*(.*)\s\s.*\n?"
test_str = ("-----------1------------\n"
"path/to/file1\n"
"real 0.21\n"
"user 0.01\n"
"sys 0.02\n"
" 11378688 maximum resident set size\n"
"-----------2------------\n"
"path/to/file2\n"
"real 0.21\n"
"user 0.01\n"
"sys 0.02\n"
" 11378688 maximum resident set size\n"
"-----------3------------\n"
"path/to/file3\n"
"real 0.21\n"
"user 0.01\n"
"sys 0.02\n"
" 11378688 maximum resident set size\n"
"-----------4------------\n"
"path/to/file4\n"
"ERROR: Lorem ipsum error\n"
"ERROR2: Lorem ipsum error 2\n"
"real 0.59\n"
"user 0.01\n"
"sys 0.02\n"
" 11378688 maximum resident set size")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.