import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[A-Za-z][0-9][A-Za-z0-9]\\.[A-Za-z0-9]{1,4}\\b";
final String string = "A24.L text text \n"
+ "text A2F.L9 text text text \n"
+ " text text text A2F.LG4 text ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}