use strict;
my $str = 'client/bower-components/angular-datatables/dist/angular-datatables.js
client/bower-components/angular-datatables/dist/angular-datatables.min.js
client/bower-components/angular-datatables/dist/plugins/bootstrap/angular-datatables.bootstrap.js
client/bower-components/angular-datatables/dist/plugins/bootstrap/angular-datatables.bootstrap.min.js
client/bower-components/datatables/media/css/jquery.dataTables.min.css';
my $regex = qr/^.*(?<!\.min)\.js$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}