package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)entest`)
var str = `members/kaleem/
members/kaleem/activity/just-me/
members/kaleem/activity/
members/kaleem/activity/favorites/
members/kaleem/activity/groups/
members/kaleem/friends/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}