# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^function|[ ;}\n=]function)(|[ ]+[a-zA-Z_0-9]*[ ]*)([(]([^()]|(?3))*[)])[ \n]*([{]([^{}]|(?5))*[}])//g;t' <<< "function(hjsjds(asasa)){kldsklsdjskhd ={ b = function(){ }; } ;ksdjdskdk jksjdsdsdksnn}
"