import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*\\[\\d+]";
final String string = "1 Afghanistan 6.4\n"
+ "2 Albania 22.9\n"
+ "3 Algeria 7.7\n"
+ "4 Angola 5.7\n"
+ "5 Argentina 37.2\n"
+ "6 Armenia 22.0\n"
+ "7 Australia 34.3 [2]\n"
+ "8 Austria 43.4";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}