#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)leakedbb\.com\-[0-9]+x[0-9]+.+[0-9]+x[0-9]+"
Local $sString = "leakedbb.com-1200x1600_67bd2cbd2fe26eab9480356a35c80eb9-1152x1536" & @CRLF & _
"leakedbb.com-1200x1600_67bd2cbd2fe26eab9480356a35c80eb9"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")