using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"leakedbb\.com\-[0-9]+x[0-9]+.+[0-9]+x[0-9]+";
string input = @"leakedbb.com-1200x1600_67bd2cbd2fe26eab9480356a35c80eb9-1152x1536
leakedbb.com-1200x1600_67bd2cbd2fe26eab9480356a35c80eb9";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}