use strict;
my $str = 'Here? some text
Here? Some text
Here! some text
Here! Some text
Here. some text
Here. Some text
Here… some text
Here… Some text ';
my $regex = qr/([.?:;!…])( )([A-Z])/mp;
my $subst = '$1\\n$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";