const regex = /^(?:(?!foo).)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?!foo).)*$', 'gm')
const str = `foo
aaa bbb`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);