$re = '/^(.*?)\s+(\d+(?:[a-z]?[, ]+\d+)*)(?=,|$)/m';
$str = 'Sokolov 19, 20, 23 ,25
Hertzl 80,82,84,86
Hertzl 80a,82b,84e,90
Aba Hillel Silver 2,3,5,6,
Weizman 8
Ahad Ha\'am 9 13 29';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);