import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=Scenario).+?\\bdog\\b.+?(?=Scenario|$)";
final String string = "Scenario: lady swallows fly Given a lady and lady swallows a \"fly\" then lady lives\n\n"
+ "Scenario: lady swallows spider Givendoga a lady and lady swallows a \"fly\",\"spider\" then lady lives\n\n"
+ "Scenario: lady swallows everything Given a lady and lady swallows a \"fly\",\"spider\",\"cat\",\"dog\",\"cow\" then badog lady Dies Scenario: lady swallows fly Given a lady and lady swallows a \"fly\" then lady lives\n\n"
+ "Scenario: lady swallows spider Given a lady and lady swallows a \"fly\",\"spider\" then lady lives\n\n"
+ "Scenario: lady swallows everything Given a lady and lady swallows a \"fly\",\"spider\",\"cat\",\"dog\",\"cow\" then lady Dies";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}