Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
((http(s)?[:\/\/]{1,}))?([a-z0-9\-]{1,}[.])([a-z0-9\-]{1,}[.])?([a-z]{2,3})(.{1,})?
/
ig
Input 1
1
New
http://example.com http://subdom.example.com http://example.uk https://example.com https://subdom.example.com https://example.uk http://example.com/?query=butt http://subdom.example.com/?query=butt http://example.uk/?query=butt https://example.com/?query=butt https://subdom.example.com/?query=butt https://example.uk/?query=butr tasdfa .ss