#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\[([^\]]*)\]"
Local $sString = "[This regex tester " & @CRLF & _
"evaluates JavaScript regular expressions]" & @CRLF & _
"" & @CRLF & _
"[This regex tester evaluates JavaScript regular expressions]" & @CRLF & _
"" & @CRLF & _
"[This regex tester " & @CRLF & _
"evaluates JavaScript " & @CRLF & _
"regular expressions]" & @CRLF & _
"s dflsf" & @CRLF & _
"sdf " & @CRLF & _
"sf" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"sflsjf" & @CRLF & _
"sjfslfj" & @CRLF & _
"sldkfj" & @CRLF & _
"lsdfj" & @CRLF & _
"f<br>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")