$re = '/\[([^\]]*)\]/';
$str = '[This regex tester
evaluates JavaScript regular expressions]
[This regex tester evaluates JavaScript regular expressions]
[This regex tester
evaluates JavaScript
regular expressions]
s dflsf
sdf
sf
sflsjf
sjfslfj
sldkfj
lsdfj
f<br>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);