# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[([^\]]*)\]"
test_str = ("[This regex tester \n"
"evaluates JavaScript regular expressions]\n\n"
"[This regex tester evaluates JavaScript regular expressions]\n\n"
"[This regex tester \n"
"evaluates JavaScript \n"
"regular expressions]\n"
"s dflsf\n"
"sdf \n"
"sf\n\n\n"
"sflsjf\n"
"sjfslfj\n"
"sldkfj\n"
"lsdfj\n"
"f<br>\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.