package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)<fontColor:#([a-z0-9]*)>(.*?)<\/fontColor>`)
var str = `<fontColor:#ff0000> January 30, 2011\n </fontColor><fontColor:#ff0010> Feb 1, 1999\n </fontColor><fontColor:#ff0050> Feb 2, 1970\n </fontColor>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}