$re = '/\<.+?\|(?<login>.*?)\>\s+(?<message>.+)/m';
$str = '@<sadf|jan.kowalski10> Thanks for something';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);