// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\<.+?\|(?<login>.*?)\>\s+(?<message>.+)").unwrap();
let string = "@<sadf|jan.kowalski10> Thanks for something";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}