# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"id=\"\d*\".*<location id=\"2703\">"
test_str = "<item id=\"42200027\" xmlns=\"urn:microsoft-dynamics-nav/xmlports/WebStoreExportRemains\"><locations><location id=\"2704\"><rest_qty>0.00</rest_qty><expected_qty>0.00</expected_qty><expected_date/></location></locations></item><item id=\"42200028\" xmlns=\"urn:microsoft-dynamics-nav/xmlports/WebStoreExportRemains\"><locations><location id=\"2703\"><rest_qty>0.00</rest_qty><expected_qty>0.00</expected_qty><expected_date/></location></locations></item><item id=\"42200029\" xmlns=\"urn:microsoft-dynamics-nav/xmlports/WebStoreExportRemains\"><locations><location id=\"2703\"><rest_qty>0.00</rest_qty><expected_qty>0.00</expected_qty><expected_date/></location></locations></item><item id=\"42200030\" xmlns=\"urn:microsoft-dynamics-nav/xmlports/WebStoreExportRemains\"><locations><location id=\"2703\"><rest_qty>0.00</rest_qty><expected_qty>0.00</expected_qty><expected_date/></location></locations></item><item id=\"42200031\" xmlns=\"urn:microsoft-dynamics-nav/xmlports/WebStoreExportRemains\"><locations><location id=\"2705\"><rest_qty>0.00</rest_qty><expected_qty>0.00</expected_qty><expected_date/></location></locations></item><item id=\"42200032\" xmlns=\"urn:microsof^Ct-dynamics-nav/xmlports/WebStoreExportRemains\"><locations><location id=\"2703\"><rest_qty>0.00</rest_qty><expected_qty>0.00</expected_qty><expected_date/></location></locations></item><item id=\"42200033\" xmlns=\"urn:microsoft-dynamics-nav/xmlports/WebStoreExportRemains\"><locations><location id=\"2703\"><rest_qty>0.00</rest_qty><expected_qty>0.00</expected_qty><expected_date/></location></locations></item><item id=\"42200034\" xmlns=\"urn:microsoft-dynamics-nav/xmlports/WebStoreExportRemains\"><locations><location id=\"2703\"><rest_qty>0.00</rest_qty><expected_qty>0.00</expected_qty><expected_date/></location></locations></item><item id=\"42200035\" xmlns=\"urn:microsoft-dynamics-nav/xmlports/WebStoreExportRemains\"><locations><location id=\"2703\"><rest_qty>0.00</rest_qty><expected_qty>0.00</expected_qty><expected_date/></location></locations></item><item id=\"42200036\" xmlns=\"urn:microsoft-dynamics-nav/xmlports/WebStoreExportRemains\"><locations><location id=\"2703\"><rest_qty>0.00</rest_qty><expected_qty>0.00</expected_qty><expected_date/></location></locations></item><item id=\"42200037\" xmlns=\"urn:microsoft-dynamics-nav/xmlports/WebStoreExportRemains\"><locations><location id=\"2703\"><rest_qty>0.00</rest_qty><expected_qty>0.00</expected_qty><expected_date/></location></locations></item><item id=\"42200038\" xmlns=\"urn:microsoft-dynamics-nav/xmlports/WebStoreExportRemains\"><locations><location id=\"2703\"><rest_qty>0.00</rest_qty><expected_qty>0.00</expected_qty><expected_date/></location></locations>"
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.