import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^((?!error|empty).)*$)";
final String string = "varformals : PAR_OPEN PAR_CLOSE {}\n"
+ "| PAR_OPEN varform PAR_CLOSE {}\n"
+ "/* error / | error PAR_CLOSE {}\n"
+ "/ error / | error varform PAR_CLOSE {}\n"
+ "/ error */ | PAR_OPEN error PAR_CLOSE {}\n"
+ ";";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}