package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[(\d*)\]<\[(\d*)\]`)
var str = `[]<[]
[1]<[2]
[123]<[456]
[]<[123]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}