package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(#\w+)`)
var str = `С Новым годом! #новыйгод:)
#лол
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}