#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?:(?<=,)|^)(?=("(?:[^"]+(?:"")*)*"|[^",]*))\1,"
Local $sString = ""3,14","1,000,000",hippo,"cat,dog,frog",plain text,"2,25""
Local $sSubst = "\1;"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)