const regex = new RegExp('(?:(?<=,)|^)(?=("(?:[^"]+(?:"")*)*"|[^",]*))\\1,', 'g')
const str = `"3,14","1,000,000",hippo,"cat,dog,frog",plain text,"2,25"`;
const subst = `\1;`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);