#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)https?:\/\/my\.matterport\.com\/show\/\??(m=(?<code>[\w\d]+))"
Local $sString = "https://my.matterport.com/show/?m=kiVrPJ4GLGF&brand=0&ts=2" & @CRLF & _
"https://my.matterport.com/show/?m=8QLBuW5dxqB&brand=0&ts=3&help=1" & @CRLF & _
"https://my.matterport.com/show/?m=vycyVs9Xe9W"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")