re = /https?:\/\/my\.matterport\.com\/show\/\??(m=(?<code>[\w\d]+))/m
str = 'https://my.matterport.com/show/?m=kiVrPJ4GLGF&brand=0&ts=2
https://my.matterport.com/show/?m=8QLBuW5dxqB&brand=0&ts=3&help=1
https://my.matterport.com/show/?m=vycyVs9Xe9W'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end