// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\/\*\*[\s\S]*?@config\s*(\{[\s\S]*?\})[\s\S]*?\*\/\s*[\#\.]?([\w-]+)\s*(?:[\#\.]*([\w-]+)\s*)*{").unwrap();
let string = "Works all one one line..
/**
*
* Some ignored comments here...
* @config { name:'Orange Title (70pt)'}
*/
h1.title_orange {
}
Works on multiple lines, with extra lines in comment
/**
*
* Some ignored comments here...
* @config {
name:'Green Title (70pt)',
order:1
}
*/
div.green_title {
}
Workson multiple lines, with extra lines in comment
/**
* @config { name:'Blue Title (70pt)',
order:1 }
* comments coud be here
*
*/
span.blue {
}
THis doesnt work due to the mutliple classes..... Not sure what im going to do with this yet, probably just match the first one - I suppose we could have multiple @config attributes matched in order to the definitions, but that sounds very hard....
/**
* @config { name:'Blue Title (70pt)'}
*/
div.blue, div.bigBlue {
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}