#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mui)(?=\b(?:Что|в)\b)(.{5})"
Local $sString = "Hi How Are you" & @CRLF & _
"Привет! Как дела, что делаешь? Не ходи в кино!" & @CRLF & _
"а наши люди в булочную на такси не ездят" & @CRLF & _
"Hi How Are you"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")