const regex = /(?=\b(?:Что|в)\b)(.{5})/gmui;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=\\b(?:Что|в)\\b)(.{5})', 'gmui')
const str = `Hi How Are you
Привет! Как дела, что делаешь? Не ходи в кино!
а наши люди в булочную на такси не ездят
Hi How Are you`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}