g modifier: global. Finds all matches instead of stopping after the first
m modifier: multiline. Causes ^ and $ to match the start and end of each line, not only the start and end of the string
u modifier: unicode. Treats the pattern and subject as UTF-16
i modifier: insensitive. Matches without distinguishing uppercase and lowercase letters