import re
regex = re.compile(r"(?=\b(?:Что|в)\b)(.{5})", flags=re.MULTILINE | re.UNICODE | re.IGNORECASE)
test_str = ("Hi How Are you\n"
"Привет! Как дела, что делаешь? Не ходи в кино!\n"
"а наши люди в булочную на такси не ездят\n"
"Hi How Are you")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")