use strict;
my $str = '$(\'#btn-new-reg, #btn-save-reg, #btn-del-reg, #btn-adv-search, #btn-prev-reg, #btn-next-reg, #btn-prev-field, #btn-next-field\').addClass(\'btnDisabled\')
// código entre o que me interessa
$("#btn-save-reg, #btn-del-reg, #btn-adv-search, #btn-prev-reg, #btn-next-reg, #btn-next-field").addClass("btnDisabled")
$("#btn-save-reg, #btn-del-reg, #btn-prev-reg, #btn-next-reg, #btn-next-field").removeClass("btnDisabled")
\\$\\([\'|"](.[^\\)]*)[\'|"]\\)\\.addClass\\([\'|"]btnDisabled[\'|"]\\)';
my $regex = qr/\$\(['|"](.[^\)]*)['|"]\)\.addClass\(['|"]btnDisabled['|"]\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}