$re = '/\$\([\'|"](.[^\)]*)[\'|"]\)\.addClass\([\'|"]btnDisabled[\'|"]\)/m';
$str = '$(\'#btn-new-reg, #btn-save-reg, #btn-del-reg, #btn-adv-search, #btn-prev-reg, #btn-next-reg, #btn-prev-field, #btn-next-field\').addClass(\'btnDisabled\')
// código entre o que me interessa
$("#btn-save-reg, #btn-del-reg, #btn-adv-search, #btn-prev-reg, #btn-next-reg, #btn-next-field").addClass("btnDisabled")
$("#btn-save-reg, #btn-del-reg, #btn-prev-reg, #btn-next-reg, #btn-next-field").removeClass("btnDisabled")
\\$\\([\'|"](.[^\\)]*)[\'|"]\\)\\.addClass\\([\'|"]btnDisabled[\'|"]\\)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);