// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
  let regex = Regex::new(r#"(?m)\$\(['|"](.[^\)]*)['|"]\)\.addClass\(['|"]btnDisabled['|"]\)"#).unwrap();
  let string = "$('#btn-new-reg, #btn-save-reg, #btn-del-reg, #btn-adv-search, #btn-prev-reg, #btn-next-reg, #btn-prev-field, #btn-next-field').addClass('btnDisabled')
// código entre o que me interessa 
$(\"#btn-save-reg, #btn-del-reg, #btn-adv-search, #btn-prev-reg, #btn-next-reg, #btn-next-field\").addClass(\"btnDisabled\")
$(\"#btn-save-reg, #btn-del-reg, #btn-prev-reg, #btn-next-reg, #btn-next-field\").removeClass(\"btnDisabled\")
\\$\\(['|\"](.[^\\)]*)['|\"]\\)\\.addClass\\(['|\"]btnDisabled['|\"]\\)";
  
  // result will be an iterator over tuples containing the start and end indices for each match in the string
  let result = regex.captures_iter(string);
  
  for mat in result {
    println!("{:?}", mat);
  }
}