re = /\(?\d{3}\)?-\d{3}-\d{4}/m
str = '123-456-7890
(123)-456-7890
(abc)-123-4567
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end